1. Este sitio usa cookies. Si continuas usando este sitio, estás aceptando el uso de nuestras cookies. Learn More.

Instalacion de magento Beta 1 en Local

Tema en 'Instalación y Configuración' comenzado por imported_magentoadmin, 9 de Septiembre de 2007.

    • Vamos a la zona de descargas de la web de Magento y descargamos Magento http://www.magentocommerce.com/download .

    • Una vez tenemos el archivo Magento-B1Preview-0.6.zip en nuestro disco duro lo descomprimimos copiamos el contenido de la carpeta magento y lo pegamos en el directorio raiz de nuestro servidor.

      [​IMG]


    • Creamos una base de datos para Magento desde phpmyadmin.

    • Editamos el archivo httpd.conf donde pone
      #LoadModule rewrite_module modules/mod_rewrite.so

      le quitamos la almohadilla # dejandolo asi

      LoadModule rewrite_module modules/mod_rewrite.so


      Buscamos en el archivo Directory y donde se encuentre el nuestro por ejemplo <Directory "C:/servidor/www"> buscamos

      AllowOverride None

      y lo dejamos asi

      AllowOverride All

    • Editamos el archivo php.ini donde pone
      ;extension=php_mcrypt.dll

      le quitamos el punto y coma ; dejandolo asi

      extension=php_mcrypt.dll


      --------------------------------------------------------------------------------

      ;extension=php_pdo_mysql.dll

      le quitamos el punto y coma ; dejandolo asi

      extension=php_pdo_mysql.dll


      --------------------------------------------------------------------------------

      allow_url_fopen=off

      dejandolo asi

      allow_url_fopen=on


      --------------------------------------------------------------------------------

      memory_limit = 8M

      dejandolo asi

      memory_limit = 20M

    • Descarga la libreria php_pdo_mysql.zip una vez en el disco duro descomprimela y pegala en la carpeta ext de php php/ext
    • Reinicia apache.
    • Abre un navegador y conectate a la url http://localhost/install/ y comenzaremos la instalacion la primera pantalla que nos encontramos son los terminos y condiciones de uso de magento si estamos de acuerdo aceptamos y pinchamos en continuar.

      [​IMG]


    • La segunda pantalla es la de configuracion en la seccion Database Connection en ella configuramos los datos de nuestra conexion a la base de datos servidor usuario pass y nombre de la base de datos que usaremos para magento.

      [​IMG]

      rellenamos los datos de Default Store en

      host pondremos localhost

      base path dejaremos /

      Protocol http

      port 80

      En Secure Connection ponemos exactamente lo mismo que en Default Store incluido el protocolo http pulsamos continuar


    • La siguiente pantalla nos permitira configurar nuestra cuenta de admin rellenamos los datos que nos solicitan excepto Encryption Key que si quereis la podeis dejar en blanco y magento nos la generara una vez rellenado todo pinchamos en continuar .

      [​IMG]


    • En esta ultima pantalla veremos nuestra clave de encriptacion que copiaremos y guardaremos en un lugar seguro.

      [​IMG]

      Solo nos queda pinchar en go to frontend para ver nuestra tienda funcionando http://localhost/

      [​IMG]

      o pinchar en go to backend para acceder a la administracion de nuestra tienda http://localhost/admin/

      [​IMG]
     
  1.  
    Comunidad Magento orgullosamente patrocinada por www.FactoriaDigital.com, expertos en hosting y vps magento.
  2. OSdave

    OSdave Super Moderador Miembro del Equipo

    hola,
    Es mi primer mensaje aqui, y seguro que no el ultimo: ¡este magento tiene una pinta estupenda!
    Bueno, al grano.

    Estoy intentando instalar magento en local (windows XP, SP2, Apache2, php 5.2.3) y no lo consigo.
    He seguido todos los pasos de instalacion, reverificado cada uno 5 veces y no hay manera.

    Cuando voy a http://localhost/magento/install/ me dice: "500 Internal Server Error".

    Tambien pasa que si navego en mi osc (http://localhost/osc/) me sale a cada clic un warning de windows:
    . Segun entiendo el mensaje, no encuentra la dll pero te aseguro que esta: he adjuntado una captura de pantalla donde se ve.

    A ver si a alguien se le ocurre el problema y la solucion, porque yo no puedo.
    saludos

    pd: ya veras si crear un nuevo tema por eso...
     
  3. Jemact

    Jemact Super Moderador Miembro del Equipo

    OSdave descarga la libreria que te adjunto y reemplaza la que tienes creo que con eso ya se solucionara el tema de la dll.

    Libreria php_pdo_mysql.dll

    El mensaje de internal error parece que no este usando el htaccess vualve aprobar una vez reinstalada la libreria y reiniciado el apache.

    Si sigue fallando comentalo para ver que puede ser.

    Un saludo :eek:k:
     
  4. OSdave

    OSdave Super Moderador Miembro del Equipo

    hola Jemact, gracias por responder.
    Pos nope, no ha funcionado. He cambiado el nombre de la antigua dll, he descomprimido y puesto la de tu link en C:\php4win\ext\ y he reiniciado el Apache y sigue igual: no encuentra la libreria :(

    No se si importa, instale php, Aapche y MySQL segun las instruccione de Eward Tanguay, no por el WAMP.

    ¿Con que puedo abrir la dll para ver si esta bien? Lo he intentado con el crimson pero no lo entiende.
    O quizas el más facil seria esperar la version definitiva, siendo una beta quizas es normal...
    ¿Que crees?

    salu2
     
  5. Jemact

    Jemact Super Moderador Miembro del Equipo

    Que version de php estas usando la 4?

    Un saludo :eek:k:
     
  6. OSdave

    OSdave Super Moderador Miembro del Equipo

    no no, la 5.2.3 (es lo que me aparece en el phpinfo())
    ya que estoy:
    Apache 2.0.59
    MySQL: 5.0.45
    por si sirve de algo...
    gracias
     
  7. Jemact

    Jemact Super Moderador Miembro del Equipo

    Otra pregunta mas en el archivo php.ini has buscado

    ;extension=php_mcrypt.dll

    y lo has reemplazado por

    extension=php_mcrypt.dll

    y

    ;extension=php_pdo_mysql.dll

    lo has reemplazado por

    extension=php_pdo_mysql.dll

    Un saludo :eek:k:
     
  8. OSdave

    OSdave Super Moderador Miembro del Equipo

    exacto, he descomentado (o sea he quitado el semi-colon) de estas 2 lineas...
    mientras tanto, he buscado en frances y he encontrado un foro de magento donde dan más explicaciones: http://www.fragento.org/index.php?option=com_fireboard&Itemid=4&func=view&id=5&catid=6

    Alli dicen de descomentar en el php.ini tambien:
    .
    Lo he hecho y ¡ya no me aparece el alert windows que dice que no encuentra la libreria! :ymca:
    Pero sigue dandome el error 500 cuando quiero hacer la instalacion.

    Asi que he intentado seguir con las explicaciones que dan...
    El paso siguiente, segun dicen, es, en el my.cnf (en /xampp/mysql/bin), comentar esto:
    Primer problema, no he encontrado ningun my.cnf :( pero si un my.ini en C:\Archivos de programa\MySQL\MySQL Server 5.0\)
    Alli veo que el skip-innodb ya esta comentado.

    Luego dicen de DEScomentar todo eso:
    Código:
    innodb_data_home_dir = C:/xampp/mysql/data/
    innodb_data_file_path = ibdata1:10M:autoextend
    innodb_log_group_home_dir = C:/xampp/mysql/data/
    innodb_log_arch_dir = C:/xampp/mysql/data/
    # You can set .._buffer_pool_size up to 50 - 80 %
    # of RAM but beware of setting memory usage too high
    set-variable = innodb_buffer_pool_size=16M
    set-variable = innodb_additional_mem_pool_size=2M
    # Set .._log_file_size to 25 % of buffer pool size
    set-variable = innodb_log_file_size=5M
    set-variable = innodb_log_buffer_size=8M
    innodb_flush_log_at_trx_commit=1
    set-variable = innodb_lock_wait_timeout=50
    En mi fichero no tengo todas estas lineas, algunas si y las que estan ya estan descomentadas...

    ¿progresamos?
     
  9. Jemact

    Jemact Super Moderador Miembro del Equipo

    Una cosa mas que sabemos :eek:k:

    De todas maneras el error ese que te da al intentar acceder al install yo diria que es porque no tienes configurado para usar htacess en windows.

    Un saludo
     
  10. OSdave

    OSdave Super Moderador Miembro del Equipo

    ¿y tienes una idea de como puedo configurar el apache para que tome en cuenta el htaccess?
    De lo que he encontrado en GG solo hace falta poner All al AllowOverride del <Directory> y esto:
    Código:
    AccessFileName .htaccess
    
    #
    # The following lines prevent .htaccess and .htpasswd files from being 
    # viewed by Web clients. 
    #
    <FilesMatch "^\.ht">
      Order allow,deny
      Deny from all
    </FilesMatch>
    Lo que esta ya asi...
    Incluso he intentado esto (en el httpd.conf)
    Código:
    <Directory "C:/phpweb/magento">
      Options Indexes FollowSymLinks
      AllowOverride All
      Order allow,deny
      Allow from all
    </Directory>
    pero sin exito
     
  11. Jemact

    Jemact Super Moderador Miembro del Equipo

    Si en el httpd.conf C:/phpweb/magento es el raiz de tu servidor eso esta correcto

    Código:
    <Directory "C:/phpweb/magento">
      Options Indexes FollowSymLinks
      AllowOverride All
      Order allow,deny
      Allow from all
    </Directory>
    
    y te quedaria editar

    Código:
    #LoadModule rewrite_module modules/mod_rewrite.so
    por 
    LoadModule rewrite_module modules/mod_rewrite.so
    
    Creo que con eso deberia bastar para permitirte usar urls cortas no te olvides de parar y volver a arrancar los servicios

    Un saludo :eek:k:
     
  12. OSdave

    OSdave Super Moderador Miembro del Equipo

    OLE OLE Y OLE, lo he conseguido!!! :ymca:
    La verdad que habia empezado esta respuesto con:
    me he leido y he pensado, "joder, no puede ser, venga!".
    Lo que hice al final es instalarme el XAMPP, y despues seguir las instrucciones.
    Lo unico, cuando se dice que hay que reiniciar el apache, no basta desde la consola de XAMPP: hay que ir a "administrador de tareas" (en windows) y terminar el proceso apache.exe dese alli, a lo bruto.

    Pero ya esta, porfin tengo el magento en local!!! :eek:k:
    Muchas gracias a Jemact por tu apoyo y a por ello! :bleh: :boxeo:
     
  13. shgarcia

    shgarcia Super Moderador Miembro del Equipo

    enhorabuena

    Felicidades por la resolución, si es que la frase
    es el motor principal de muchas soluciones...
    ahora a trastearlo que es lo que mola!

    Un saludo
    shgarcia
     
  14. Xan

    Xan Nuevo usuario

    Buenas,

    Alguien ha probado la instalación local en Mac? con el mamp.

    Salud!
     
  15. HecHu

    HecHu Nuevo usuario

    Hola que tal he intentado instalar Magento, primero tenia muchos errores utilizaba easyphp, tenia los errores ke mencionan en los post mas atras, despues me descargue el xampp y segui los pasos del manual y ya entro a la pag de instalacion pero lleguo a una parte y no me deja continuar mas abajo dejo lo que me sale:

    o PHP Extension "mcrypt" must be loaded
    o PHP Extension "curl" must be loaded

    Supuse que hay ke activar esas extenciones asi ke me diriji al php.ini y les kite el ; para activarlas (reinicie todos los servicios) pero nada no se si alguien sepa como solucionar este error.

    Saludos !!!!!!
     
  16. aiglesias

    aiglesias Nuevo usuario

    problemita con la instalacion

    hola a todos,
    Es mi primer mensaje aqui, y espero que no el ultimo:
    Bueno, al toro.

    Estoy intentando instalar magento en local (windows XP, SP2, XAMPP para Windows Version 1.6.6a) y no lo consigo.
    He seguido todos los pasos de instalacion, reverificado cada uno 5 veces y no hay manera.

    Cuando voy sin ningún problema hasta la parte de Download Updates , aqui parece que falla y
    da lo siguiente:
    Setting preferred state to: beta

    config-set succeeded

    Downloading and installing Magento, please wait...

    Ignoring installed package pear/PEAR
    Ignoring installed package mage-core/Mage_Pear_Helpers
    Ignoring installed package mage-core/Lib_ZF
    mage-core/Lib_Varien requires PHP extension "curl"
    mage-core/Mage_All requires package "mage-core/Lib_Varien" (version >= 0.9.17740, version <= 0.9.17740)
    mage-core/Mage_All requires PHP extension "curl"
    mage-core/Interface_Frontend_Default requires package "mage-core/Mage_All" (version >= 0.9.17740, version <= 0.9.17740)
    mage-core/Interface_Adminhtml_Default requires package "mage-core/Mage_All" (version >= 0.9.17740, version <= 0.9.17740)
    mage-core/Interface_Install_Default requires package "mage-core/Mage_All" (version >= 0.9.17740, version <= 0.9.17740)
    Array
    (
    [data] => Array
    (
    [0] => Array
    (
    [0] => No valid packages found
    )

    )

    [headline] => Install Errors
    )


    PEAR ERROR: install failed

    -----
    después en la parte de configuration da error "PHP Extension "curl" must be loaded"

    ¿le ha pasado a alguien ?¿Cual es el problema? y la solución
    saludos

    Gracias de antemano :hola:
     
    Última modificación: 21 de Marzo de 2008
  17. junnecito

    junnecito Nuevo usuario

    Buenos dias a todos:
    Necesito ayuda por favor en la programación de las paginas de Magento, me estoy volviendo loco y no se que hacer.
    Espero vuestra ayuda y muchas gracias
     
  18. fpagon

    fpagon Nuevo usuario

    Hola... no se si ya lo hayas hecho, pero creo que tu error podrías quitarlo si activas la librería CURL; en el php.ini debes modificar la siguiente línea:
    ;extension=php_curl.dll , quítale el ';'; debería quedar así: extension=php_curl.dll
     
  19. junnecito

    junnecito Nuevo usuario

    Buenos días a tod@s:
    OSdave, veo que eres un genio con magento, me gustaría hacerte una pregunta!
    Tengo instalado magento en my pc y estoy trabajando con el backend para crear productos y tratar de configurarlo un poco, cuando voy frontend no me sale la pantalla del magento ni mis productos, me sale una pagina de magento demo store y una frase de bienvenida que cree.
    Podrias por favor ayudarme y decirme lo que estoy haciendo mal? me estoy quedando sin pelos en la cabeza de tanto hacer y no ver los resultados.
    Agradeciendo tu ayuda.
    Un saludo
     
  20. aiglesias

    aiglesias Nuevo usuario

    Esta hecho y sigue igual.

    Gracias :hola:
     
Cargando...

Comparte esta página

Usuarios en línea

Total: 15 (miembros: 0, invitados: 9, robots: 6)

Estadísticas del foro

Temas:
6.438
Mensajes:
28.070
Miembros:
3.759
Miembro más reciente:
Guillermo006